Legacy Browsers Requirements

   Journey PlatformPreviously known as the Transact Platform.

The Journey platform doesn't support the following legacy desktop browsers:

  • Internet Explorer 8
  • Internet Explorer 9
  • Internet Explorer 10

Microsoft no longer supports these browsers and doesn’t provide security patches or fixes for zero day exploits making them a significant security risk and liability to customers, form users, and Temenos. For more information, refer to the following documentation:

In addition, these legacy browsers don’t support modern security standards required for secure transactions to take place:

In Journey Manager 4.3.3 and higher, customers must explicitly configure their environments to support IE10, IE9 or IE8 because its default configuration doesn’t support them.

Warning

Customers enabling legacy browsers do so at their own risk.

Next, learn what Temenos supports.